Sales: +44 (0) 782 570 0260
Login
Request Demo
Login
Request Demo

Mailtastic System Requirements

EasySync Mac

  • Mac OS Version 10.11 or higher
  • Outlook for Mac Version 16.0 or higher
  • Apple Mail Version V3 or higher (was preinstalled from Mac OS Version 10.11 on)

EasySync Windows

  • .NET Framework 4.5 or higher
  • Windows 7 or higher (on 14.01.2020 MS will end support for Windows 7)
  • Outlook Version 2013 (Ribbon) or higher
  • Every Outlook Version except the Microsoft Store version

Chrome Plugin (EasySync 4G)

  • Chrome Browser in the current version or up to two versions older

WebApp

  • Chrome, Firefox or Edge Browser in the current version or up to two versions older

Rerouting

  • Microsoft Exchange Online or MS Exchange Hybrid configuration where Exchange Online will deliver the mail to mailboxes outside the company